Todo List: Removing glib/gtk from make/optdepends

2014-05-17 - Eric Bélanger

We are going to remove the old glib and gtk packages from the repos [1]. Obviously, packages that require them will also be removed. This todo list is for packages which has a make/optdepends on either glib, gtk or a package that has glib/gtk in its dependency tree. Remove gtk support or patch to build without gtk if possible. Push the updated packages straight in the [extra] or [community] repos.

[1]https://mailman.archlinux.org/pipermail/arch-dev-public/2014-April/026121.html

Link to lists of pkgbase values:

Filter Todo List Packages

Select filter criteria
17 packages displayed out of 17 total packages.
Arch Repository Name Current Version Staging Version Maintainers Status Last Touched By
i686 Community collectd 5.6.0-1 bisson Complete bisson
x86_64 Community collectd 5.6.0-1 bisson Complete bisson
i686 Extra flac 1.3.1-3 eric Complete eric
x86_64 Extra flac 1.3.1-3 eric Complete eric
i686 Community gerbv 2.6.1-4 kkeen Complete eric
x86_64 Community gerbv 2.6.1-4 kkeen Complete eric
i686 Extra libdv 1.0.0-6 jgc Complete eric
x86_64 Extra libdv 1.0.0-6 jgc Complete eric
i686 Community librcc 0.2.12-1 spupykin Complete spupykin
x86_64 Community librcc 0.2.12-1 spupykin Complete spupykin
any Community perlpanel 20080729-6 spupykin Complete spupykin
i686 Community twin 0.6.2-7 spupykin Complete spupykin
x86_64 Community twin 0.6.2-7 spupykin Complete spupykin
i686 Community xmms2 0.8DrO_o.919.gece0baf-4 spupykin Complete spupykin
x86_64 Community xmms2 0.8DrO_o.919.gece0baf-4 spupykin Complete spupykin
i686 Community xosd 2.2.14-8 spupykin Complete spupykin
x86_64 Community xosd 2.2.14-8 spupykin Complete spupykin