Todo List: remove cloog/isl dependency in gcc packages

2014-11-03 - Allan McRae

The latest isl is incompatible with gcc. The patch we carry is a hack, and I am fairly convinced does the wrong thing.

I have built gcc-4.9.2 using in tree builds of isl/cloog. This uses the latest compatible (and upstream recommended) isl/cloog versions. Check on the PKGUILD in SVN.

I suggest everyone does the same. If you really want to keep the isl/cloog deps, you can have them in [community] once gcc-4.9.2 hits [core].

As an aside, why is mingw-w64-gcc-base in the repos?

Link to lists of pkgbase values:

Filter Todo List Packages

Select filter criteria
6 packages displayed out of 6 total packages.
Arch Repository Name Current Version Staging Version Maintainers Status Last Touched By
x86_64 Community arm-none-eabi-gcc 8.2.0-1 anatolik Complete anatolik
x86_64 Community avr-gcc 8.2.0-1 anatolik Complete schuay
x86_64 Core gcc 8.2.1+20180831-1 bpiotrowski Complete allan
x86_64 Multilib gcc-multilib Complete allan
x86_64 Community mingw-w64-gcc Complete spupykin
x86_64 Community mingw-w64-gcc-base Complete spupykin