New NPTL repository

I've moved the NTPL-related packages from our Testing repository and stuck 'em in a special "NPTL" repository, which you can add to your pacman.conf like any other repo. If you want to use the NPTL glibc then I suggest you put this repo at the top of your list in pacman.conf.

[nptl] Server =

Warning: You need a 2.6.x kernel to use this glibc!

Eventually, I'd like to use this NPTL-enabled glibc as standard in Arch, but we're not ready to leave behind the 2.4.x users quite yet.