Eclipse Update

I've updated Eclipse to Europa ( and the CDT to (4.0.1) in extra, after a stint in testing.

With this release, eclipse moves from /opt into /usr/share and drops support for JDK 1.4.x, which is several years old and no longer straightforward to support.

If you rely on JDK 1.4.x and are willing to help modify our eclipse package to better support it, please open a feature request in Flyspray.