Eclipse 3.4

Packages for eclipse 3.4-3 and eclipse-cdt 5.0.0-2 will appear shortly in extra.

We've switched to using the binary distributions for optimal stability and compatibility.

It appeared that installing the binary distributions in /opt/eclipse was required; however, we have since determined that everything works fine with eclipse in /usr/share.

Eclipse will stay in /usr/share.